summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2021-11-22 04:31:53 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-23 10:35:30 +0100
commiteb82a95fc475d91c75ef97fdcabbd6f42d04464a (patch)
treea24c3a7c55122907b80492a2b9342d81797ab76a
parent8be21b1b31b1ca9058158e4767df3e776a2ed426 (diff)
downloadguix-eb82a95fc475d91c75ef97fdcabbd6f42d04464a.tar.gz
gnu: Add python-orgparse.
* gnu/packages/python-xyz.scm (python-orgparse): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fdbca24b6e..34d4910194 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28039,6 +28039,33 @@ simple mock/record and a complete capture/replay framework.")
 interfaces.")
     (license license:bsd-3)))
 
+(define-public python-orgparse
+  (package
+    (name "python-orgparse")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "orgparse" version))
+       (sha256
+        (base32 "14iv4pg3rma9560plg0w943x04mr2cmrssda43y2d1x9acrd2n71"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv" "orgparse/tests")))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
+    (home-page "https://github.com/karlicoss/orgparse")
+    (synopsis "Emacs Org mode parser in Python")
+    (description
+     "This package is a Python module for reading Emacs Org mode files.")
+    (license license:bsd-3)))
+
 (define-public python-sgmllib3k
   (package
     (name "python-sgmllib3k")