summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:53:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:53:34 +0200
commitb495fbfad9cd04ffe387d812fc126777bdf6e40d (patch)
treed71adb834308fa3cbacb20323368142eb5115bdc
parentb8e4626542184df54f563b88e86b59f6b4f5130f (diff)
downloadguix-b495fbfad9cd04ffe387d812fc126777bdf6e40d.tar.gz
gnu: emacs-helm-mode-manager: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-helm-mode-manager)[source]: Download
using git-fetch.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4c3c7a1fac..a4eed54127 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13365,13 +13365,14 @@ grouping buffers by their projectile root directory.")
     (version "1.0.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/istib/helm-mode-manager/"
-                           "archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/istib/helm-mode-manager")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0wllj321z16hgrx0ddwzk5wz4mnnx5am7w5nclqclfc5dfdn92wm"))))
+         "1srx5f0s9x7zan7ayqd6scxfhcvr3nkd4yzs96hphd87rb18apzk"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-helm" ,emacs-helm)))