summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:21:49 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:01:59 -0400
commit06153a30891d3aba0bf415713c5cc1b6db6a7cc8 (patch)
tree8cebd10f6cf3fbaa31aaec457fedfd0927335523
parent8c3101b87783041697b4d4c79f8dc5dd6d7b4281 (diff)
downloadguix-06153a30891d3aba0bf415713c5cc1b6db6a7cc8.tar.gz
gnu: proot: Use invoke.
* gnu/packages/linux.scm (proot)[arguments]: Use invoke and remove vestigial
plumbing.
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 07a9b0080d..5543d231d4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4241,24 +4241,23 @@ userspace queueing component and the logging subsystem.")
                         (setenv "PATH"
                                 (string-append (getenv "PATH") ":/bin"))
 
-                        (zero? (system* "make" "check" "-C" "tests"
-                                        ;;"V=1"
-                                        "-j" (number->string n))))))
+                        (invoke "make" "check" "-C" "tests"
+                                ;;"V=1"
+                                "-j" (number->string n)))))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
                       ;; The 'install' rule does nearly nothing.
-                      (let ((out (assoc-ref outputs "out")))
-                        (and (zero?
-                              ;; TODO: 'make install-care' (does not even
-                              ;; build currently.)
-                              (system* "make" "-C" "src" "install"
-                                       (string-append "PREFIX=" out)))
-                             (let ((man1 (string-append out
-                                                        "/share/man/man1")))
-                               (mkdir-p man1)
-                               (copy-file "doc/proot/man.1"
-                                          (string-append man1 "/proot.1"))
-                               #t))))))))
+                      (let* ((out (assoc-ref outputs "out"))
+                             (man1 (string-append out "/share/man/man1")))
+                        ;; TODO: 'make install-care' (does not even
+                        ;; build currently.)
+                        (invoke "make" "-C" "src" "install"
+                                (string-append "PREFIX=" out))
+
+                        (mkdir-p man1)
+                        (copy-file "doc/proot/man.1"
+                                   (string-append man1 "/proot.1"))
+                        #t))))))
     (native-inputs `(("which" ,which)
 
                      ;; For 'mcookie', used by some of the tests.