summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 12:52:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 12:52:30 +0100
commit0633c77b1bea9ca671dc1e6495bd1835b99e18fb (patch)
tree172ff9b4f12f472d858d61f1f9348ef7cb4b2767
parent112fcafbae40cbae66b55eac02119799051fc354 (diff)
downloadguix-0633c77b1bea9ca671dc1e6495bd1835b99e18fb.tar.gz
gnu: xdelta: Fetch sources from git.
* gnu/packages/compression.scm (xdelta)[source]: Fetch from git.
-rw-r--r--gnu/packages/compression.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index f831535578..3fd219e5f4 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1047,13 +1047,14 @@ smaller than those produced by @code{Xdelta}.")
     (version "3.1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/jmacd/xdelta/archive/v"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jmacd/xdelta.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "17g2pbbqy6h20qgdjq7ykib7kg5ajh8fwbsfgyjqg8pwg19wy5bm"))
-       (file-name (string-append name "-" version ".tar.gz"))
+         "09mmsalc7dwlvgrda56s2k927rpl3a5dzfa88aslkqcjnr790wjy"))
        (snippet
         ;; This file isn't freely distributable and has no effect on building.
         '(begin