summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:32:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:12 +0200
commit0b9f426caf67a1df6fd12ae7b2b2e15aee8a3cc7 (patch)
treed9101c129428b865ded5583b5cb0e2c5e0d43146
parent5696dc2373e5b9f5dcb6b0643c842b1c334eef18 (diff)
downloadguix-0b9f426caf67a1df6fd12ae7b2b2e15aee8a3cc7.tar.gz
gnu: emacs-evil-matchit: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-evil-matchit)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4065f77e54..39be50d891 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8313,14 +8313,13 @@ Feautures:
     (version "2.2.9")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/redguardtoo/evil-matchit/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/redguardtoo/evil-matchit.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1i5a7szl0m3xnqyjq6zhg5j68x9fgf9ffxghj918c4brj4436sjb"))))
+        (base32 "12if45pxfndy3d7r4gd3zx4d3jk4d64fdmwkhc3y5zhqq9h9iy4c"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-evil" ,emacs-evil)))