summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-18 12:46:51 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-01 23:41:42 +0200
commit0e05bee4bed6c2a2df72296c15f6726c24e2bdc7 (patch)
tree2b06b60327a1e1238dc9cfc9d27a89a0167cc1d5
parent150cf64b04dcb370124e02a5bb347e0617bae20c (diff)
downloadguix-0e05bee4bed6c2a2df72296c15f6726c24e2bdc7.tar.gz
gnu: python-pycryptodomex: Unbundle libtomcrypt.
* gnu/packages/python-crypto.scm
  (python-pycryptodomex)[source]{snippet}: Unbundle libtomcrypt.
  (python-pycryptodomex)[source]{modules}: Add (guix build utils).

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-crypto.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6d50ae682f..cec57f9fda 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1025,7 +1025,9 @@ PyCryptodome variants, the other being python-pycryptodomex.")
        (method url-fetch)
        (uri (pypi-uri "pycryptodomex" version))
        (sha256
-        (base32 "0lbx4qk3xmwqiidhmkj8qa7bh2lf8bwzg0xjpsh2w5zqjrc7qnvv"))))
+        (base32 "0lbx4qk3xmwqiidhmkj8qa7bh2lf8bwzg0xjpsh2w5zqjrc7qnvv"))
+       (modules '((guix build utils)))
+       (snippet pycryptodome-unbundle-tomcrypt-snippet)))
     (description
      "PyCryptodome is a self-contained Python package of low-level
 cryptographic primitives.  It's not a wrapper to a separate C library like