summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-08 22:06:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-08 22:08:39 +0200
commit2df4ecd61d663211b3ce5a0036e25ff143b3b4b1 (patch)
treead86e388e2c518cfc585a65ee2af8071bb85521e
parentcfe62fb22b96c76efde2872398d2814df3ecf113 (diff)
downloadguix-2df4ecd61d663211b3ce5a0036e25ff143b3b4b1.tar.gz
gnu: python-dbus: Update to 1.2.8.
* gnu/packages/python.scm (python-dbus): Update to 1.2.8.
[inputs]: Replace "python" with "python-wrapper".
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 84683a9d16..65daba4e4b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4873,15 +4873,15 @@ toolkit.  Use it to build trees of widgets.")
 (define-public python-dbus
   (package
     (name "python-dbus")
-    (version "1.2.0")
+    (version "1.2.8")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://dbus.freedesktop.org/releases/dbus-python/dbus-python-"
-             version ".tar.gz"))
+       (uri (string-append "https://dbus.freedesktop.org/releases/dbus-python/"
+                           "dbus-python-" version ".tar.gz"))
        (sha256
-        (base32 "1py62qir966lvdkngg0v8k1khsqxwk5m4s8nflpk1agk5f5nqb71"))))
+        (base32
+         "0vvvjmiwnc9cjlks3gcdk43ap7llhlpz7cm1wbw0nc2yfsxjpwdb"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -4897,7 +4897,7 @@ toolkit.  Use it to build trees of widgets.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("python" ,python)
+     `(("python" ,python-wrapper)
        ("dbus-glib" ,dbus-glib)))
     (synopsis "Python bindings for D-bus")
     (description "python-dbus provides bindings for libdbus, the reference