summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-09 10:45:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-09 10:49:27 +0200
commit2efc787811a2c4586b763aeed319cb3777e7aa37 (patch)
treefc0f0399adeedac6078931b3a39b42102ebb5dbe
parent38d024dc58ec7d7fc951bf96da0143e7ce3d145b (diff)
downloadguix-2efc787811a2c4586b763aeed319cb3777e7aa37.tar.gz
gnu: Add r-ciara.
* gnu/packages/bioconductor.scm (r-ciara): New variable.
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fd9ff0c678..1bb8c0d406 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11989,6 +11989,30 @@ genes in the gene-set that are ranked above the leading edge).")
      "This package provides a pipeline for analysing Capture Hi-C data.")
     (license license:artistic2.0)))
 
+;; This is a CRAN package, but it depends on Bioconductor packages, so we put
+;; it here.
+(define-public r-ciara
+  (package
+    (name "r-ciara")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "CIARA" version))
+              (sha256
+               (base32
+                "0nr7wks9231326x0lhpbh824c6vcb5hr5jn89s9bmg9mci907bsf"))))
+    (properties `((upstream-name . "CIARA")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase r-ggplot2 r-ggraph r-magrittr))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=CIARA")
+    (synopsis "Cluster-independent algorithm for rare cell types identification")
+    (description
+     "This is a package to support identification of markers of rare cell
+types by looking at genes whose expression is confined in small regions of the
+expression space.")
+    (license license:artistic2.0)))
+
 (define-public r-cicero
   (package
     (name "r-cicero")