summary refs log tree commit diff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:43 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:35:21 -0500
commit36017770f7cbd49d9d5752c4e8b72cb685a549cd (patch)
treebe48e41131d02286201f42293ebfb69c1b9e5cb0
parent90eae236aa9d1cffa0c759ec1f7967ebbef57f5e (diff)
downloadguix-36017770f7cbd49d9d5752c4e8b72cb685a549cd.tar.gz
gnu: Add ghc-wai-handler-launch.
* gnu/packages/haskell-web.scm (ghc-wai-handler-launch): New variable.

Signed-off-by: Timothy Sample <samplet@ngyro.com>
-rw-r--r--gnu/packages/haskell-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 63c644f992..51a54566a7 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2197,3 +2197,30 @@ syntactic elements, without changing the semantics.")
     (description "This package provides a static file serving subsite
 for the Yesod Web Framework.")
     (license license:expat)))
+
+(define-public ghc-wai-handler-launch
+  (package
+    (name "ghc-wai-handler-launch")
+    (version "3.0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "wai-handler-launch/wai-handler-launch-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1ifqgyc1ccig5angh5l1iq7vyms4lvi8wzvysg5dw82nml49n02m"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-wai" ,ghc-wai)
+       ("ghc-warp" ,ghc-warp)
+       ("ghc-http-types" ,ghc-http-types)
+       ("ghc-streaming-commons" ,ghc-streaming-commons)
+       ("ghc-async" ,ghc-async)))
+    (home-page "https://hackage.haskell.org/package/wai-handler-launch")
+    (synopsis "Launch a Web application in the default browser")
+    (description "This package handles cross-platform Web browser
+launching and inserts JavaScript code to ping the server.  When the
+server no longer receives pings, it shuts down.")
+    (license license:expat)))