summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-05 16:05:02 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-13 20:56:30 -0700
commit3691e37eb14c5871d213646154b98f5aaa5dd2f1 (patch)
tree968dfabfc85539d04fac721b727c1deb773b2a10
parent4ff9f1689d0d8f3c7555c472ce67aaa928af564d (diff)
downloadguix-3691e37eb14c5871d213646154b98f5aaa5dd2f1.tar.gz
gnu: autogen: Build with guile 3.0.
* gnu/packages/autogen.scm (autogen)[arguments]: Add 'support-guile-3.0 phase.
  [inputs]: Remove guile-2.2 and add guile-3.0.
-rw-r--r--gnu/packages/autogen.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index d0c8df17ec..d0e4f2f34c 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -49,7 +49,7 @@
             "def_bf[MAXNAMELEN + 10]")))))
     (build-system gnu-build-system)
     (native-inputs (list pkg-config which))
-    (inputs (list guile-2.2 perl))          ; for doc generator mdoc
+    (inputs (list guile-3.0 perl))          ; for doc generator mdoc
     (arguments
      '(#:configure-flags
        ;; XXX Needed to build 5.18.16.  ./configure fails without it:
@@ -62,6 +62,17 @@
 
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'support-guile-3.0
+           ;; Upstream bug:
+           ;; https://sourceforge.net/p/autogen/bugs/196/
+           ;;
+           ;; Supported in Debian and openSUSE:
+           ;; https://salsa.debian.org/debian/autogen/-/blob/master/debian/patches/40_suse_04-guile-version.patch
+           (lambda _
+             (substitute* "agen5/guile-iface.h"
+               (("#elif GUILE_VERSION < 203000") "#elif GUILE_VERSION < 301000"))
+             (substitute* "configure"
+               (("2.2 2.0 1.8") "3.0 2.2 2.0 1.8"))))
          (add-before 'build 'set-man-page-date
            ;; Avoid embedding the current date for reproducible builds
            (lambda _