summary refs log tree commit diff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-18 19:50:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-18 13:47:25 +0200
commit49380a3a8613d1a9e13007fe3b4bf094ba9b3ffd (patch)
tree806ff0e646ddbb51af5dfec61d4a25daf1b20f54
parent01005f426958ab9e12f44c5e4a60ec1cdd605d5d (diff)
downloadguix-49380a3a8613d1a9e13007fe3b4bf094ba9b3ffd.tar.gz
gnu: Add rust-named-pipe-0.4.
* gnu/packages/crates-io.scm (rust-named-pipe-0.4): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a54789fc88..e35cf774b5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7430,6 +7430,29 @@ checking.")
       "Chaining APIs for both self -> Self and &mut self methods.")
     (license license:expat)))
 
+(define-public rust-named-pipe-0.4
+  (package
+    (name "rust-named-pipe")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "named-pipe" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0azby10wzmsrf66m1bysbil0sjfybnvhsa8py093xz4irqy4975d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t     ; Only builds on Windows.
+       #:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))
+    (home-page "https://github.com/blackbeam/named_pipe")
+    (synopsis "Wrapper for overlapped (asyncronous) IO of Windows's named pipes")
+    (description "This package provides a wrapper for overlapped (asyncronous)
+IO of Windows's named pipes.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-natord-1.0
   (package
     (name "rust-natord")