summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 21:18:32 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 21:19:28 +0200
commit4cd369ed6b0c095d9bb9a5550e84eba22630677d (patch)
treeab8ce80416ce1ee3f67189a49fcec043b4436daa
parente8444b26ab43b413cfe1c7d11d70030613d83bb6 (diff)
downloadguix-4cd369ed6b0c095d9bb9a5550e84eba22630677d.tar.gz
gnu: Add libabw.
* gnu/packages/libreoffice.scm (libabw): New variable.
-rw-r--r--gnu/packages/libreoffice.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 481ab21fc6..1c5b195310 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -199,3 +199,33 @@ ZVR (simple compressed text format).")
     (description "The libwpg project provides a library and tools for
 working with graphics in the WPG (WordPerfect Graphics) format.")
     (license (list mpl2.0 lgpl2.1+))))            ;dual licensed
+
+(define-public libabw
+  (package
+    (name "libabw")
+    (version "0.1.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+                          name "-" version ".tar.xz"))
+      (sha256 (base32
+               "0zi1zj4fpxgpglbbb5n1kg3dmhqq5rpf46lli89r5daavp19iing"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("gperf" ,gperf)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("boost" ,boost)
+       ("librevenge" ,librevenge)
+       ("libxml2" ,libxml2)))
+    (arguments
+     ;; avoid triggering configure errors by simple inclusion of boost headers
+     `(#:configure-flags '("--disable-werror")))
+    (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libabw")
+    (synopsis "Library for parsing the AbiWord format")
+    (description "Libabw is a library that parses the file format of
+AbiWord documents.")
+    (license mpl2.0)))