summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-20 00:26:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-28 21:54:50 +0100
commit4ed3f7e35969cc7881b11923d6832a4bd5b528db (patch)
tree18e6e7cef259129ede71275a35353b8723be4895
parent76ed409e22ccc646ead95e45a069fcc908cc4b89 (diff)
downloadguix-4ed3f7e35969cc7881b11923d6832a4bd5b528db.tar.gz
gnu: Add rust-futures-join-macro-preview-0.3.
* gnu/packages/crates-io.scm (rust-futures-join-macro-preview-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 36566d65f3..84044adb96 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10057,6 +10057,31 @@ for the futures-rs library.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-futures-join-macro-preview-0.3
+  (package
+    (name "rust-futures-join-macro-preview")
+    (version "0.3.0-alpha.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "futures-join-macro-preview" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1smwaja466yjh5adlhgggfk9k942sy4702n46scxkrwcnkk61qjr"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-proc-macro-hack" ,rust-proc-macro-hack-0.5)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://rust-lang-nursery.github.io/futures-rs")
+    (synopsis "Definition of the `join!` macro and the `try_join!` macro")
+    (description
+     "This package provides the definition of the @code{join!} macro and the
+@code{try_join!} macro.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-futures-macro-0.3
   (package
     (name "rust-futures-macro")