summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-12 00:39:26 +0000
committerLeo Famulari <leo@famulari.name>2017-01-13 14:13:02 -0500
commit559115a64ea96add2b1269d939816146382ecaab (patch)
treefdc1f3afb6b1a7aa36b17d6bd7c6591698a3e378
parentd8c8e423ed67897a8cc236e68658baacdce1b5fd (diff)
downloadguix-559115a64ea96add2b1269d939816146382ecaab.tar.gz
gnu: Add skroll.
* gnu/packages/suckless.scm (skroll): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/suckless.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index c9465b9fea..002c9273ba 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -345,3 +345,31 @@ is essencially a WiFi DoS attack tool created for educational
 purposes only.  It works only in Linux and requires wireless card
 drivers capable of injecting packets in wireless networks.")
     (license license:gpl3+)))
+
+(define-public skroll
+  (package
+    (name "skroll")
+    (version "0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://dl.2f30.org/releases/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0km6bjfz4ssb1z0xwld6iiixnn7d255ax8yjs3zkdm42z8q9yl0f"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; No tests
+       #:make-flags (list "CC=gcc"
+                          (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)))) ; No configure script
+    (home-page "http://2f30.org")
+    (synopsis "Commandline utility which scrolls text")
+    (description
+     "Skroll is a small utility that you can use to make a text scroll.
+Pipe text to it, and it will scroll a given number of letters from right to
+left.")
+    (license license:wtfpl2)))