summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-14 15:37:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-14 15:37:25 +0200
commit57bc2dcf0bfa300dcdc52d64a201e435c4e65a2c (patch)
tree4a32f90da26fb8a6982b5749615125d274b026a1
parentc206f1914e9299b3f9a8b8be295a02f14acc67b3 (diff)
downloadguix-57bc2dcf0bfa300dcdc52d64a201e435c4e65a2c.tar.gz
gnu: commencement: Remove 'm4-boot0*'.
* gnu/packages/commencement.scm (m4-boot0*): Remove.
(bison-boot0, flex-boot0): Use M4-BOOT0 instead.
-rw-r--r--gnu/packages/commencement.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 54746151ce..0b01d4f307 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1716,12 +1716,6 @@ exec " gcc "/bin/" program
        #:implicit-inputs? #f
        ,@(package-arguments m4)))))
 
-(define m4-boot0*
-  (package
-    ;; TODO: On the next rebuild cycle, use M4-BOOT0 as is.
-    (inherit m4-boot0)
-    (name "m4")))
-
 (define bison-boot0
   ;; This Bison is needed to build MiG so we need it early in the process.
   ;; Recent versions of Linux-Libre headers also depend on this.
@@ -1729,7 +1723,7 @@ exec " gcc "/bin/" program
     (inherit bison)
     ;; TODO: On the next build cycle, do:
     ;;(name "bison-boot0")
-    (propagated-inputs `(("m4" ,m4-boot0*)))
+    (propagated-inputs `(("m4" ,m4-boot0)))
     (native-inputs `(("perl" ,perl-boot0)))
     (inputs (%boot0-inputs))                      ;remove Flex...
     (arguments
@@ -1765,12 +1759,7 @@ exec " gcc "/bin/" program
   (package
     (inherit flex)
     (native-inputs `(("bison" ,bison-boot0)))
-    (propagated-inputs
-     ;; XXX: Here we use an 'm4-boot0' package that's not eq? so that it
-     ;; appears twice in '%build-inputs', like when we were using
-     ;; 'package-with-explicit-inputs'.
-     ;; TODO: Remove this hack on the next rebuild cycle.
-     `(("m4" ,(package (inherit m4-boot0*)))))
+    (propagated-inputs `(("m4" ,m4-boot0)))
     (inputs (%boot0-inputs))
     (arguments
      `(#:implicit-inputs? #f