summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-12-09 15:52:44 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-12-09 16:18:18 -0500
commit584d5556d409e7db70296f751e7b8a123f1d5c01 (patch)
tree72c6207f2bcb967df51801fb143aff3b42e3908e
parent505a385498d9efeb006fa94ba88098422153cbb5 (diff)
downloadguix-584d5556d409e7db70296f751e7b8a123f1d5c01.tar.gz
gnu: python-jedi: Update to 0.13.1 and disable the tests.
Jedi test suite fails when run with Python 3.7.

* gnu/packages/python.scm (python-jedi): Update to 0.13.1
[tests?] Disable.
[phases] Add condition check for the tests? argument to run the tests.
-rw-r--r--gnu/packages/python.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9472a441ef..23b980ec32 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9841,20 +9841,25 @@ characters, mouse support, and auto suggestions.")
 (define-public python-jedi
   (package
     (name "python-jedi")
-    (version "0.12.1")
+    (version "0.13.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "jedi" version))
        (sha256
         (base32
-         "1h8ypnjisn57kiv1zqrkj1im6sbfnhxllqaa8znh39qkd47ys2dl"))))
+         "0j11q42g5vjkyhhjpyy8nb0gdxs78m3rpjai7p1hvgpyl9rkyjdp"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
+     `( ;; Many tests are failing with Python 3.7.x as of version 0.13.1 (see:
+        ;; https://github.com/davidhalter/jedi/issues/1263)
+       #:tests? #f
+       #:phases
        (modify-phases %standard-phases
-         (replace 'check (lambda _
-                           (invoke "py.test" "-vv"))))))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "py.test" "-vv")))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-docopt" ,python-docopt)))