summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 10:30:26 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:44 +0200
commit681a02916dc58a9c8723ed1d35fabd23a54a5c81 (patch)
tree94c7c6c34ee4b9b1e71cb2f22d0cdc47612d7525
parent474a3da8e4c8691ce9343ea1e72a8e214df3099d (diff)
downloadguix-681a02916dc58a9c8723ed1d35fabd23a54a5c81.tar.gz
gnu: sbcl-uffi: Remove Make reference from closure.
* gnu/packages/lisp-xyz.scm (sbcl-uffi)[source]: Delete the 'debian' folder.

This takes the closure size from 209 MiB down to 151 MiB.
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d0f8ca824c..a1528d16ce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10354,7 +10354,13 @@ interface for MySQL, PostgreSQL and SQLite.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1hqszvz0a3wk4s9faa83sc3vjxcb5rxmjclyr17yzwg55z733kry"))))
+        (base32 "1hqszvz0a3wk4s9faa83sc3vjxcb5rxmjclyr17yzwg55z733kry"))
+       (modules '((guix build utils)))
+         (snippet
+          ;; The useless bundled debian folder drags `make' into the closure.
+          `(begin
+             (delete-file-recursively "debian")
+             #t))))
     (build-system asdf-build-system/sbcl)
     (arguments
      `(#:tests? #f ; TODO: Fix use of deprecated ASDF functions