summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 17:38:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-12 17:43:31 -0500
commit7b15e14a904c732d7c950b8a624904308d5b869f (patch)
treea67b1da1dee46da2e3c84cfe47a187d54ecd35a4
parent9c6a1d69333c89ad726fede844e1f391162ea218 (diff)
downloadguix-7b15e14a904c732d7c950b8a624904308d5b869f.tar.gz
gnu: fpc: Fix it, really.
* gnu/packages/pascal.scm (fpc): Inputs are controlled to be package-like
objects, so the previous attempt also failed.
[native-inputs]{fpc-binary}: Backtrack to the original solution, which is to
use the x86_64 bootstrap input for unsupported architectures.
-rw-r--r--gnu/packages/pascal.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/pascal.scm b/gnu/packages/pascal.scm
index 74daf058ca..e199f981a1 100644
--- a/gnu/packages/pascal.scm
+++ b/gnu/packages/pascal.scm
@@ -93,14 +93,15 @@
        ("zlib" ,zlib)))
     (native-inputs
      ;; FPC is built with FPC, so we need bootstrap binaries.
-     `(("fpc-binary"
-        (match ,(or (%current-target-system)
-                    (%current-system))
-          ("i686-linux" ,fpc-bootstrap-i386)
-          ;;("powerpc64le-linux" ,fpc-bootstrap-ppc64le)
-          ;;("powerpc-linux" ,fpc-bootstrap-ppc)
-          ("x86_64-linux" ,fpc-bootstrap-x86_64)
-          (arch (error "fpc arch not yet supported in guix" arch))))))
+     `(("fpc-binary" ,(match (or (%current-target-system)
+                                 (%current-system))
+                       ("i686-linux" fpc-bootstrap-i386)
+                       ;;("powerpc64le-linux" fpc-bootstrap-ppc64le)
+                       ;;("powerpc-linux" fpc-bootstrap-ppc)
+                       ("x86_64-linux" fpc-bootstrap-x86_64)
+                       ;; XXX: Wrong, but innocuous so long
+                       ;; `supported-systems' is kept in sync.
+                       (_ fpc-bootstrap-x86_64)))))
     (arguments
      `(#:tests? #f ; no tests available
        #:phases