summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:04 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:25 +0200
commit8208e0d72d47c174991da297f8c934517b30351e (patch)
tree198aa12c1af6bcd84fdfce50dbe6b3e9404984ed
parent95f6e2c60a3790869f0a0754a1c2a028cabd6406 (diff)
downloadguix-8208e0d72d47c174991da297f8c934517b30351e.tar.gz
gnu: Add trytond-account-invoice-correction.
* gnu/packages/tryton.scm (trytond-account-invoice-correction): New variable.
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4b588f5974..0a57265067 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -628,6 +628,31 @@ term.")
 (define-public python-trytond-account-invoice
   (deprecated-package "python-trytond-account-invoice" trytond-account-invoice))
 
+(define-public trytond-account-invoice-correction
+  (package
+    (name "trytond-account-invoice-correction")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_invoice_correction" version))
+       (sha256
+        (base32 "152jxsl6v2wclk1wjhykbyvianh47cp2yg575hkx18dfynyp7nmw"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_invoice_correction"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-invoice-correction")
+    (synopsis "Tryton module to correct invoice")
+    (description "The @emph{Account Invoice Correction} Tryton module adds a
+wizard on invoice which allows select lines for which the unit price must be
+corrected.  A new invoice is created with those lines in double: once with the
+original quantity, once with the inverted quantity.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice-stock
   (package
     (name "trytond-account-invoice-stock")