summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 17:55:20 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 23:00:21 +0200
commit8b1f117187ad224058381b086b5c258a229cdf2b (patch)
tree2c6c3c51bb5db2f6142caacd67dcc5fcf37f03ba
parent8eeadc8cb8dce9b918ffe5048758936d2bf1ebd6 (diff)
downloadguix-8b1f117187ad224058381b086b5c258a229cdf2b.tar.gz
gnu: python-beautifulsoup4: Update to 4.11.1.
* gnu/packages/python-xyz.scm (python-beautifulsoup4): Update to 4.11.1.
[arguments]: Override check phase.
[native-inputs]: Add PYTHON-PYTEST.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 21106bf832..2f5fe120bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9386,15 +9386,23 @@ the GObject Introspection bindings to libnotify for non-GTK applications.")
 (define-public python-beautifulsoup4
   (package
     (name "python-beautifulsoup4")
-    (version "4.10.0")
+    (version "4.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "beautifulsoup4" version))
        (sha256
         (base32
-         "14c8z4gh9bi38agx9ls8ym5rscc02pc6f6hmliaqk08xa8yd4fn2"))))
+         "14v68cpfzckfz63n9hnbsm271jvzvxscyijz83mhha7gcmdsb6md"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-vv")))))))
+    (native-inputs
+     (list python-pytest))
     (propagated-inputs
      (list python-soupsieve python-html5lib python-lxml))
     (home-page