summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-27 09:04:55 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-19 12:45:40 +0200
commit96a320e5c7cb80d613e47eca48ef68641fa3344f (patch)
tree0aa6ca0ef1c497264acfe43b748ba3e742827b15
parenta9a507613b15272a0a4e89bd7a2160734205fc46 (diff)
downloadguix-96a320e5c7cb80d613e47eca48ef68641fa3344f.tar.gz
gnu: tome4: Use make-desktop-entry-file.
* gnu/packages/games.scm (tome4)[arguments]: Do it.
-rw-r--r--gnu/packages/games.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2ed505bbc4..839fc155cd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5259,19 +5259,13 @@ Crowther & Woods, its original authors, in 1995.  It has been known as
                         (copy-recursively "game" (string-append data "/game"))
                         ;; launcher
                         (mkdir-p applications)
-                        (with-output-to-file (string-append applications "/"
-                                                            ,name ".desktop")
-                          (lambda ()
-                            (display
-                             (string-append
-                              "[Desktop Entry]
-Name=ToME4
-Comment=" ,synopsis "\n"
-"Exec=" ,name "\n"
-"Icon=" icon "\n"
-"Terminal=false
-Type=Application
-Categories=Game;RolePlaying;\n")))))
+                        (make-desktop-entry-file
+                         (string-append applications "/" ,name ".desktop")
+                         #:name "ToME4"
+                         #:comment ,synopsis
+                         #:exec ,name
+                         #:icon icon
+                         #:categories '("Game" "RolePlaying")))
                       #t)))))
     (home-page "https://te4.org")
     (description "Tales of Maj’Eyal (ToME) RPG, featuring tactical turn-based