summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-08 23:01:04 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 23:00:21 +0200
commitac1aace34eef67b8b448057de6e172d0156b4721 (patch)
treef270f84888a6d6c192fb075ee2a6aefe72f6ef9e
parent835938ad61bfedd9f52fe6114a4e0b8ee72c0588 (diff)
downloadguix-ac1aace34eef67b8b448057de6e172d0156b4721.tar.gz
gnu: python-pytest-benchmark: Update to 3.4.1.
* gnu/packages/python-check.scm (python-pytest-benchmark): Update to 3.4.1.
[arguments]: Add #:test-target.
[native-inputs]: Remove PYTHON-PATHLIB2.
-rw-r--r--gnu/packages/python-check.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5ee1d41f34..2358e7448d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1249,19 +1249,21 @@ for the @code{pytest} framework.")
 (define-public python-pytest-benchmark
   (package
     (name "python-pytest-benchmark")
-    (version "3.2.3")
+    (version "3.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-benchmark" version))
        (sha256
         (base32
-         "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+         "0ivvrnhax2xr62grlgw4hlyjmmjp6nc35431j7c82nny2bwn7qj0"))))
     (build-system python-build-system)
+    (arguments
+     '(#:test-target "check"))
     (propagated-inputs
      (list python-py-cpuinfo))
     (native-inputs
-     (list python-pathlib2 python-pytest))
+     (list python-pytest))
     (home-page "https://github.com/ionelmc/pytest-benchmark")
     (synopsis "Pytest fixture for benchmarking code")
     (description