summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-01 21:32:04 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:32 -0500
commitb2563bc335c4da931ecd5196f0208907560c8353 (patch)
tree8d98add1527d7ff1eaef2082b3d64fd31630bdc6
parent0a2a79de9700315dd66098851e770f4814d6b889 (diff)
downloadguix-b2563bc335c4da931ecd5196f0208907560c8353.tar.gz
gnu: gvfs: Use meson-0.59 to workaround faulty meson.
Meson 0.60 now hard fails on errors it previously only warned about.

* gnu/packages/gnome.scm (gvfs)[meson]: Use meson-0.59.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e9dd63fe1e..b1cb69b257 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6564,7 +6564,8 @@ part of udev-extras, then udev, then systemd.  It's now a project on its own.")
                 "1hlxl6368h6nyqp1888szxs9hnpcw98k3h23dgqi29xd38klzsmj"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t
+     `(#:meson ,meson-0.59
+       #:glib-or-gtk? #t
        #:configure-flags
        (list "-Dsystemduserunitdir=no"
              "-Dtmpfilesdir=no"
@@ -6572,7 +6573,7 @@ part of udev-extras, then udev, then systemd.  It's now a project on its own.")
              (string-append "-Dc_link_args=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib/gvfs"))))
     (native-inputs
-     `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+     `(("glib:bin" ,glib "bin")         ;for glib-genmarshal, etc.
        ("gettext" ,gettext-minimal)
        ("gtk-doc" ,gtk-doc/stable)
        ("pkg-config" ,pkg-config)