summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-08 04:26:04 +0000
committerLeo Famulari <leo@famulari.name>2021-11-08 12:22:13 -0500
commitb6e1ba61042c14c9391514472e436e29b2a5167d (patch)
tree14cc0d0c1a34d76f835f14a240fed3384d64d568
parent2d2f50b30c4f9a8afd1279a6b97d400802086b04 (diff)
downloadguix-b6e1ba61042c14c9391514472e436e29b2a5167d.tar.gz
gnu: libavif: Restrict dependency on rav1e to x86_64.
* gnu/packages/image.scm (libavif)[arguments]<#:configure-flags>: Pass
"-DAVIF_CODEC_RAV1E=ON" only on x84_64.
<#:phases>: Don't return #t.
[inputs]: Add rav1e only on x86_64.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/image.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index fc021dd2db..ff3963e6f5 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2182,7 +2182,11 @@ This package can be used to create @code{favicon.ico} files for web sites.")
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
-                           "-DAVIF_CODEC_RAV1E=ON"
+                           ,@(if (string-prefix? "x86_64"
+                                                 (or (%current-target-system)
+                                                     (%current-system)))
+                                 '("-DAVIF_CODEC_RAV1E=ON")
+                                 '())
                            "-DAVIF_BUILD_TESTS=ON")
        #:phases
        (modify-phases %standard-phases
@@ -2193,12 +2197,16 @@ This package can be used to create @code{favicon.ico} files for web sites.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (doc (string-append out "/share/doc/libavif-" ,version)))
-               (install-file "../source/README.md" doc)
-               #t))))))
+               (install-file "../source/README.md" doc)))))))
     (inputs
      `(("dav1d" ,dav1d)
        ("libaom" ,libaom)
-       ("rav1e" ,rav1e)))
+       ;; XXX: rav1e depends on rust, which currently only works on x86_64.
+       ;; See also the related configure flag when changing this.
+       ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+                                          (%current-system)))
+             `(("rav1e" ,rav1e))
+             '())))
     (synopsis "Encode and decode AVIF files")
     (description "Libavif is a C implementation of @acronym{AVIF, the AV1 Image
 File Format}.  It can encode and decode all YUV formats and bit depths supported