summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-05-25 17:04:51 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 17:11:32 +0200
commitd2c06bf2ff424c6076b3e847119a3952f7a6ce40 (patch)
tree2a39fa8aa1a75d20a68f5f128dc64e39e3f7dfa5
parente0e1bf440937b3f68d29839fb7c5d70061a3129d (diff)
downloadguix-d2c06bf2ff424c6076b3e847119a3952f7a6ce40.tar.gz
platforms: Remove the s390x platform.
Turns out this platform doesn't have a bootstrap tarball and should be
considered as not supported for now.

* guix/platforms/s390.scm: Remove it.
* Makefile.am (MODULES): Adapt it.
* doc/guix.texi (Foreign Architectures): Ditto.
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi2
-rw-r--r--guix/platforms/s390.scm29
3 files changed, 0 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index bc114c9dae..968bde8131 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,7 +137,6 @@ MODULES =					\
   guix/platforms/mips.scm                       \
   guix/platforms/powerpc.scm                    \
   guix/platforms/riscv.scm                      \
-  guix/platforms/s390.scm                       \
   guix/platforms/x86.scm                        \
   guix/build-system.scm				\
   guix/build-system/android-ndk.scm		\
diff --git a/doc/guix.texi b/doc/guix.texi
index 55c992ca25..bcc193366f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -15265,7 +15265,6 @@ The available targets are:
    - powerpc-linux-gnu
    - powerpc64le-linux-gnu
    - riscv64-linux-gnu
-   - s390x-linux-gnu
    - x86_64-linux-gnu
    - x86_64-w64-mingw32
 @end example
@@ -15313,7 +15312,6 @@ The available systems are:
    - powerpc-linux
    - powerpc64le-linux
    - riscv64-linux
-   - s390x-linux
 
 $ guix build --system=i686-linux hello
 /gnu/store/cc0km35s8x2z4pmwkrqqjx46i8b1i3gm-hello-2.12
diff --git a/guix/platforms/s390.scm b/guix/platforms/s390.scm
deleted file mode 100644
index b5477f1e5e..0000000000
--- a/guix/platforms/s390.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix platforms s390)
-  #:use-module (guix platform)
-  #:use-module (guix records)
-  #:export (s390x-linux))
-
-(define s390x-linux
-  (platform
-   (target "s390x-linux-gnu")
-   (system "s390x-linux")
-   (linux-architecture "s390")
-   (glibc-dynamic-linker "/lib/ld64.so.1")))