summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:12:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:02 +0200
commitd2cdc59514795a3fa951768dd0638b08881bdf73 (patch)
tree0193b0638a12084ef0971c141d092f925d87bf3e
parentd4d2492ac65ea4300668e852a0fd39ffdb0f9d28 (diff)
downloadguix-d2cdc59514795a3fa951768dd0638b08881bdf73.tar.gz
gnu: emacs-org-bullets: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-org-bullets)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 228e4ac1fd..d6a0cd1188 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3535,13 +3535,13 @@ number.")
     (version "0.2.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/sabof/org-bullets/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sabof/org-bullets.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1dyxvpb73vj80v8br2q9rf255hfphrgaw91fbvwdcd735np9pcnh"))))
+        (base32 "10nr4sjffnqbllv6gmak6pviyynrb7pi5nvrq331h5alm3xcpq0w"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/sabof/org-bullets")
     (synopsis "Show bullets in org-mode as UTF-8 characters")