summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-12 19:03:25 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-08-13 09:28:20 +0100
commitd56a29edb7e5ab24ae04869aea68befa4625c11d (patch)
tree327aba44b2a822a80b1641c93677b9aee30e9243
parentd87d6d68128c53a95fe09c3a4381575646c0f368 (diff)
downloadguix-d56a29edb7e5ab24ae04869aea68befa4625c11d.tar.gz
gnu: python-pygmsh: Update snippet for Gmsh > 4.7.0.
The old field option name is not needed after commit
78595fe3650057f258109c6599f4bae1d0e72e (Gmsh 4.8.4).

* gnu/packages/simulation.scm (python-pygmsh)[source]: Remove
option name substitution.
-rw-r--r--gnu/packages/simulation.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 96928dfa07..929399c86c 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -863,13 +863,6 @@ tools and a collection of Python modules for programmatic use.")
             ;; The extra reference is unnecessary and is removed.
             (substitute* "setup.cfg"
               (("^[[:blank:]]+setuptools>=42\n") ""))
-            ;; FIXME: gmsh version 4.7.0 introduces new field option
-            ;; names.  See gmsh commit 6eab8028.  pygmsh needs to use
-            ;; one of the old option names for compatibility with gmsh
-            ;; version 4.6.0.
-            (with-directory-excursion "pygmsh/common"
-              (substitute* "size_field.py"
-                (("NumPointsPerCurve") "NNodesByEdge")))
             #t))))
     (build-system python-build-system)
     (native-inputs