summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-16 10:33:43 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-16 10:33:43 +0200
commitd5d1e5d1d4085158f378320b429e08acfe5b8a11 (patch)
tree9aff0f2b090604a2b7370be88ee4decbaef23668
parent7ceafdf0726e118dd6d6e00e5f5f9e03b13082c1 (diff)
downloadguix-d5d1e5d1d4085158f378320b429e08acfe5b8a11.tar.gz
gnu: geeqie: Fix build.
* gnu/packages/image-viewers.scm (geeqie)[arguments]: Pass '-fcommon' to
  CFLAGS.
-rw-r--r--gnu/packages/image-viewers.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index d6344565bd..de83084cdc 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -20,6 +20,7 @@
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -312,7 +313,8 @@ actions.")
     (build-system gnu-build-system)
     (arguments
      `( ;; Enable support for a "map" pane using GPS data.
-       #:configure-flags '("--enable-map"
+       #:configure-flags '("CFLAGS=-fcommon"
+                           "--enable-map"
                            "--enable-gtk3")))
     (inputs
      `(("clutter" ,clutter)