summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-28 02:17:37 -0400
committerMark H Weaver <mhw@netris.org>2018-04-10 00:45:07 -0400
commitdf17d508052d955bc9800a871f403cd3f2b07fce (patch)
tree0fff36638b42fae32d5da0eed0f63b6db8875771
parentd57d54d18907f5ed03b0e147537b853c87d62d68 (diff)
downloadguix-df17d508052d955bc9800a871f403cd3f2b07fce.tar.gz
gnu: guile-rsvg: Restore custom bootstrap phase.
This fixes a regression introduced in commit
189be331acfda1c242a9c85fca8d2a0356742f48.

* gnu/packages/gtk.scm (guile-rsvg)[arguments]: Restore the custom bootstrap
phase that was in place prior to commit 189be33, but use invoke.
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 37402cedcd..b55af15900 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -856,6 +856,11 @@ exceptions, macros, and a dynamic programming environment.")
                     #t))
                 (file-name (string-append name "-" version ".tar.gz"))))
       (build-system gnu-build-system)
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (replace 'bootstrap
+                      (lambda _
+                        (invoke "autoreconf" "-vfi"))))))
       (native-inputs `(("pkg-config" ,pkg-config)
                        ("autoconf" ,autoconf)
                        ("automake" ,automake)