summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 23:28:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 23:39:41 +0100
commitebd2ae1858427d82a3f0ac90ad4c9951455757e4 (patch)
tree8bd2aba0b6d148dc726e0f65941033732066e1b6
parenta3dbfbbd0444f7eef23494c1110eecb5784a53b4 (diff)
downloadguix-ebd2ae1858427d82a3f0ac90ad4c9951455757e4.tar.gz
gnu: i3-wm: Remove obsolete code.
* gnu/packages/wm.scm (i3-wm)[arguments]: Remove #:make-flags.
Update reason for disabled #:tests?.
-rw-r--r--gnu/packages/wm.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f1f3c25391..c577c4021c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -15,7 +15,7 @@
 ;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;;
@@ -190,17 +190,12 @@ commands would.")
                 "0xl56y196vxv001gvx35xwfr25zah8m3xwizp9ycdgdc0rfc4rdb"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (list "CC=gcc"
-             (string-append "PREFIX=" %output)
-             ;; This works around the following error:
-             ;; 'error: ‘for’ loop initial declarations are only allowed in C99
-             ;; or C11 mode'
-             "CFLAGS=-std=c11")
+     `(#:configure-flags
        ;; The build system tries to build in a separate directory, but that
        ;; seems to be unnecessary.
-       #:configure-flags '("--disable-builddir")
-       ;; The test suite appears to require the unpackaged Perl module AnyEvent.
+       (list "--disable-builddir")
+
+       ;; The test suite requires the unpackaged Xephyr X server.
        #:tests? #f))
     (inputs
      `(("libxcb" ,libxcb)