summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-09 19:32:03 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-09 19:33:28 +0100
commitf73b7bf6e20be3429570822036a38b3f00239fa5 (patch)
tree0d51b90b6cc5b70c094f1445eb8d9e6a1ec75a4d
parentcb95e79f14716b5db94d18e16a8f84243132dac3 (diff)
downloadguix-f73b7bf6e20be3429570822036a38b3f00239fa5.tar.gz
gnu: fasm: Update comments.
* gnu/packages/assembly.scm (fasm): Update comments.
-rw-r--r--gnu/packages/assembly.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index ef5c9f6f1d..dd9e6d0dc4 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -140,18 +140,17 @@ to the clients.")
          "02wqkqxpn3p0iwcagsm92qd9cdfcnbx8a09qg03b3pjppp30hmp6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ;;no tests
-       #:strip-binaries? #f ;; fasm has no sections
+     `(#:tests? #f ; No tests exist
+       #:strip-binaries? #f ; fasm has no sections
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure) ;;no configure script used
+         (delete 'configure) ; no "configure" script exists
          (replace 'build
            (lambda _
-             ;;source code are in this directory
              (chdir "source/Linux/")
              (if (string=? ,(%current-system) "x86_64-linux")
-                 ;;use pre-compiled binaries in top-level directory to build
-                 ;;itself
+                 ;; Use pre-compiled binaries in top-level directory to build
+                 ;; fasm.
                  (invoke "../../fasm.x64" "fasm.asm")
                  (invoke "../../fasm" "fasm.asm"))))
          (replace 'install
@@ -159,7 +158,6 @@ to the clients.")
              (let ((out (assoc-ref %outputs "out")))
                (install-file "fasm" (string-append out "/bin")))
              #t)))))
-    ;;support only intel x86 family processors
     (supported-systems '("x86_64-linux" "i686-linux"))
     (synopsis "Assembler for x86 processors")
     (description