summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:53:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:52 -0400
commit018c96f0c780b1605923c427a3b6f6a0600669cf (patch)
tree007c6cf62d03bd4241126563dc6146de1880c5a0
parent42333736e05161d29aac60b6a810f56160987057 (diff)
downloadguix-018c96f0c780b1605923c427a3b6f6a0600669cf.tar.gz
gnu: Remove python2-soupsieve.
* gnu/packages/python-xyz.scm (python2-soupsieve): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 667e2ceaf7..9ba7e9ce76 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9328,25 +9328,8 @@ Soup 4.  It aims to provide selecting, matching, and filtering using modern
 CSS selectors.  Soup Sieve currently provides selectors from the CSS level 1
 specifications up through the latest CSS level 4 drafts and beyond (though
 some are not yet implemented).")
-    (properties `((python2-variant . ,(delay python2-soupsieve))))
     (license license:expat)))
 
-;; This is the last version that supports python-2
-(define-public python2-soupsieve
-  (let ((base (package-with-python2 (strip-python2-variant python-soupsieve))))
-    (package
-      (inherit base)
-      (version "1.9.6")
-      (source
-       (origin
-         (method url-fetch)
-         (uri (pypi-uri "soupsieve" version))
-         (sha256
-          (base32
-           "1apgqxngi1216h1cyvrvj9gy3wf45mh1lz4n76j26jf3k36bm1br"))))
-      (propagated-inputs
-       (modify-inputs (package-propagated-inputs base)
-         (prepend python2-backports-functools-lru-cache))))))
 
 (define-public python-netifaces
   (package