summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-28 20:20:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-29 09:18:50 +0200
commit456f97ae1ebdfaf83f29f4f9cc46c52e18ed6909 (patch)
tree16de3095a768f18c1d660a8f0890a9151e709f6d
parentb217d5da8f18497780f9eca06866117bf623bcb5 (diff)
downloadguix-456f97ae1ebdfaf83f29f4f9cc46c52e18ed6909.tar.gz
gnu: Add chicken-srfi-37.
* gnu/packages/chicken.scm (chicken-srfi-37): New variable.
-rw-r--r--gnu/packages/chicken.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index b87b8118f1..a35ef46f6b 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -156,6 +156,25 @@ a characters and be compared to other character sets")
     (license (license:non-copyleft
               "http://wiki.call-cc.org/eggref/5/srfi-14#license"))))
 
+(define-public chicken-srfi-37
+  (package
+    (name "chicken-srfi-37")
+    (version "1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (egg-uri "srfi-37" version))
+              (sha256
+               (base32
+                "10n2qyyv7n4r0m20wyzd8y6s6knc67kdh9i8gp8jgz8b05p7xy8g"))))
+    (build-system chicken-build-system)
+    (arguments '(#:egg-name "srfi-37"))
+    (native-inputs (list chicken-test))
+    (home-page "https://wiki.call-cc.org/egg/srfi-37")
+    (synopsis "SRFI-37 command-line option parsing for Chicken scheme")
+    (description "This package provides SRFI-37, a simple and flexible
+command-line option parsing facility, for Chicken scheme.")
+    (license (license:non-copyleft home-page)))) ;; TODO: refine
+
 (define-public chicken-srfi-69
   (package
     (name "chicken-srfi-69")