summary refs log tree commit diff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-15 19:53:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:30 +0200
commit4c63796545ce2a1f7cd556a831bb92c7b3166358 (patch)
treeedbea46097b5f187edff4dd6d994b6a571d16c54
parentb438836833a15ef7894b59178886728303f58f43 (diff)
downloadguix-4c63796545ce2a1f7cd556a831bb92c7b3166358.tar.gz
gnu: dub: Use G-expressions.
* gnu/packages/dlang.scm (dub)[arguments]:
Rewrite as G-expressions.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/dlang.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index c17224d1eb..9acd01ed9d 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -454,20 +454,20 @@ integration tests...\n")
         (base32 "06a4whsl1m600k096nwif83n7za3vr7pj1xwapncy5fcad1gmady"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; it would have tested itself by installing some packages (vibe etc)
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ; no configure script
-         (replace 'build
-           (lambda _
-             (setenv "CC" ,(cc-for-target))
-             (setenv "LD" ,(ld-for-target))
-             (invoke "./build.d")))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "bin/dub" bin)))))))
+     (list #:tests? #f                  ; tests try to install packages
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)      ; no configure script
+               (replace 'build
+                 (lambda _
+                   (setenv "CC" #$(cc-for-target))
+                   (setenv "LD" #$(ld-for-target))
+                   (invoke "./build.d")))
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin")))
+                     (install-file "bin/dub" bin)))))))
     (inputs
      (list curl))
     (native-inputs