summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-28 20:20:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-29 09:18:51 +0200
commit5d68638bfcf84ac5ec9012ac6d3830e8123570a2 (patch)
treecb0cf1f96c5d6d5b3ebf44a56020fec693b381f3
parent456f97ae1ebdfaf83f29f4f9cc46c52e18ed6909 (diff)
downloadguix-5d68638bfcf84ac5ec9012ac6d3830e8123570a2.tar.gz
gnu: Add chicken-args.
* gnu/packages/chicken.scm (chicken-args): New variable.
-rw-r--r--gnu/packages/chicken.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index a35ef46f6b..baab6b971a 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -348,3 +348,23 @@ primitives.  More specifically, provided are:
 @end itemize
 @end itemize")
     (license license:bsd-3)))
+
+(define-public chicken-args
+  (package
+    (name "chicken-args")
+    (version "1.6.2")
+    (source (origin
+              (method url-fetch)
+              (uri (egg-uri "args" version))
+              (sha256
+               (base32
+                "0knkg31d4dq9a8rq9g3ycmj0z6j9l7zp93qa9cnqc8ixd6jsymkm"))))
+    (build-system chicken-build-system)
+    (arguments '(#:egg-name "args"))
+    (propagated-inputs (list chicken-srfi-1 chicken-srfi-13 chicken-srfi-37))
+    (home-page "https://wiki.call-cc.org/egg/args")
+    (synopsis "Command-line argument handling, on top of SRFI 37")
+    (description "This extension provides a wrapper around
+SRFI-37 (args-fold).  The main goal is to let the user parse command-line
+arguments without having to write a lot of similar support code every time.")
+    (license license:bsd-3)))