summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-08-08 14:37:59 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2021-08-08 14:45:58 +0200
commit5db89b351061b79496a1b7fc93238bfb54b85c4d (patch)
treea73845097ff1deb6b9394098da769e09656b4fde
parenta88cf96480e85a3df2f92e0a3ae76ea9368674f6 (diff)
downloadguix-5db89b351061b79496a1b7fc93238bfb54b85c4d.tar.gz
gnu: rust-svd-parser: Update to 0.10.2.
* gnu/packages/crates-io.scm (rust-svd-parser): Update to 0.10.2.
[arguments]<#:cargo-inputs]: Remove rust-either.  Add rust-once-cell,
rust-rayon, rust-regex.
-rw-r--r--gnu/packages/crates-io.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2bbeb35c99..f19906d6a9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56627,7 +56627,7 @@ configuration file and/or environment variables.")
 (define-public rust-svd-parser-0.9
   (package
     (name "rust-svd-parser")
-    (version "0.9.0")
+    (version "0.10.2")
     (source
       (origin
         (method url-fetch)
@@ -56636,12 +56636,14 @@ configuration file and/or environment variables.")
           (string-append name "-" version ".tar.gz"))
         (sha256
           (base32
-            "1qhvdz3k76i3sfypcy8c84hhb8sqixrckba21kalzcpgy6an45ml"))))
+            "1fbr4m9cla6xvmrib7pad9hv29sn2d5hjbc77pz12lwzmm2pczk9"))))
     (build-system cargo-build-system)
     (arguments
       `(#:cargo-inputs
         (("rust-anyhow" ,rust-anyhow-1)
-         ("rust-either" ,rust-either-1)
+         ("rust-once-cell" ,rust-once-cell-1)
+         ("rust-rayon" ,rust-rayon-1)
+         ("rust-regex" ,rust-regex-1)
          ("rust-serde" ,rust-serde-1)
          ("rust-thiserror" ,rust-thiserror-1)
          ("rust-xmltree" ,rust-xmltree-0.8))