summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:23:01 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:43 +0200
commit6cf981afcdf68ce980617cc2c6b3a7896f0bcc76 (patch)
treebe0663ed010f16729bdf88a6d50e2cbc2a87084e
parent9fe3632e64290d5db052c11e5dc38af8b24d7617 (diff)
downloadguix-6cf981afcdf68ce980617cc2c6b3a7896f0bcc76.tar.gz
gnu: Add ocaml-base-bigstring.
* gnu/packages/ocaml.scm (ocaml-base-bigstring): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3e5c7e8bf2..ba21f76759 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6612,6 +6612,28 @@ driver including all standard Jane Street ppx rewriters.")
       (properties '())
       (license license:asl2.0))))
 
+(define-public ocaml-base-bigstring
+  (package
+    (name "ocaml-base-bigstring")
+    (version "0.14.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/janestreet/base_bigstring")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ald2m7qywhxbygv58dzpgaj54p38zn0aiqd1z7i95kf3bsnsjqa"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-base ocaml-ppx-jane))
+    (properties `((upstream-name . "base_bigstring")))
+    (home-page "https://github.com/janestreet/base_bigstring")
+    (synopsis "String type based on [Bigarray], for use in I/O and C-bindings")
+    (description "This package provides string type based on [Bigarray], for
+use in I/O and C-bindings.")
+    (license license:expat)))
+
 (define-public ocaml-splittable-random
   (package
     (name "ocaml-splittable-random")