summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-11 16:07:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-12 14:13:14 +0200
commit75ca0e52581f7da95f540acadada671ee08a0cda (patch)
treecc7e8e825fa667393648ff00a74f27c4abd20828
parent0b4300d4fd8c972f0cb9d6751fc824b9a065b780 (diff)
downloadguix-75ca0e52581f7da95f540acadada671ee08a0cda.tar.gz
gnu: python2-setuptools: Patch source code.
* gnu/packages/python-xyz.scm (python2-setuptools)[arguments]: Add phase
'compatibility-fixes.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab4102273a..0ef71605e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1863,7 +1863,17 @@ Python 3 support.")
     ;; FIXME: Tests require pytest, which itself relies on setuptools.
     ;; One could bootstrap with an internal untested setuptools.
     (arguments
-     `(#:tests? #f))
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'compatibility-fixes
+           (lambda _
+             ;; HTMLParser no longer exists.
+             (substitute* "setuptools/py33compat.py"
+               (("html_parser.HTMLParser\\(\\).unescape")
+                "html.unescape"))
+             ;; This needs distutils.msvc9compiler
+             (delete-file "setuptools/tests/test_msvc.py"))))))
     (native-inputs
      (list unzip))
     (home-page "https://pypi.org/project/setuptools/")