summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-28 12:25:05 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-28 12:27:42 +0200
commitb7c99f2b8864cf6b2a736d20255dd47d2c1d79d4 (patch)
tree4e59587d3104ea9b0ed174e1557136e1e36b1a44
parentaa0d30aa582d07c6fdccf6d9342801beb590a8d1 (diff)
downloadguix-b7c99f2b8864cf6b2a736d20255dd47d2c1d79d4.tar.gz
gnu: rocclr-4: Remove package.
Not useful on its own after upgrading to ROCm 5 in commit
01444b297bb3ed28bb33cd01604aadb98bb65333.

* gnu/packages/rocm.scm (rocclr-4): Remove variable.
-rw-r--r--gnu/packages/rocm.scm45
1 files changed, 0 insertions, 45 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 6c1a83cc88..b85b39d783 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -193,51 +193,6 @@ applications to launch compute kernels to available HSA ROCm kernel agents.")
      (base32
       "0x1frzpz9j1s516vscbdm9g5cqirvv5w7wmq2kyljcygnci7yqar"))))
 
-(define-public rocclr-4
-  (package
-    (name "rocclr-4")
-    (version "4.3.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/ROCm-Developer-Tools/ROCclr.git")
-                    (commit (string-append "rocm-" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1pm1y020zriz7zmi95w0rcpka0jrsc7wwh81sssnysi8wxk3nnfy"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:tests? #f ; No tests.
-       #:configure-flags
-       `(,(string-append
-           "-DOPENCL_DIR="
-           (assoc-ref %build-inputs "rocm-opencl-runtime-src")))))
-    (inputs
-     `(("mesa" ,mesa)
-       ("rocm-comgr" ,rocm-comgr)
-       ("llvm" ,llvm-for-rocm)
-       ("rocm-device-libs" ,rocm-device-libs)
-       ("rocr-runtime" ,rocr-runtime)
-       ("rocm-cmake" ,rocm-cmake)
-       ;; rocclr depends on a few headers provided by rocm-opencl-runtime.
-       ("rocm-opencl-runtime-src"
-        ,(origin
-           (method git-fetch)
-           (uri (git-reference
-                 (url "https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime.git")
-                 (commit (string-append "rocm-" version))))
-           (file-name (git-file-name name version))
-           (sha256
-            (base32
-             "1cglpiaj3ny1z74ssmy6j63vj92sfy4q38ix6qsga0mg3b2wvqz3"))))))
-    (home-page "https://github.com/ROCm-Developer-Tools/ROCclr")
-    (synopsis "Radeon Open Compute Common Language Runtime")
-    (description "ROCclr is a virtual device interface that compute runtimes
-interact with to different backends such as ROCr or PAL.  This abstraction
-allows runtimes to work on Windows as well as on Linux without much effort.")
-    (license license:ncsa)))
-
 (define-public rocm-opencl-runtime
   (package
     (name "rocm-opencl-runtime")