summary refs log tree commit diff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-05-05 21:09:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-22 08:22:40 +0200
commite4dde29e01d5041c0488e169f691b4ffa894e992 (patch)
treeee592d562ef02a313006ca90c944c2eec72d96a4
parent0e380c339b43ba38700e31c4a483e4dfc535d104 (diff)
downloadguix-e4dde29e01d5041c0488e169f691b4ffa894e992.tar.gz
gnu: Add emacs-code-cells.
* gnu/packages/emacs-xyz.scm (emacs-code-cells): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9eb8b2182d..4242149ee1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31263,6 +31263,30 @@ to the @url{https://multitran.com} online dictionary.")
 @command{python} buffers.")
     (license license:gpl3)))
 
+(define-public emacs-code-cells
+  ;; No tagged release upstream
+  (let ((commit "8660bdeedee360e5eb632f1eb1356eb09d7dfbee")
+        (revision "0"))
+    (package
+      (name "emacs-code-cells")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/astoff/code-cells.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0mvfsdlhc3znc0d2p8vm7apkbpvbs688wmwvd0sms33qly53f546"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/astoff/code-cells.el")
+      (synopsis "Emacs utilities for code split into cells, including Jupyter
+notebooks")
+      (description "This package lets you efficiently navigate, edit and
+execute code split into cells according to certain magic comments.")
+      (license license:gpl3+))))
+
 (define-public emacs-kibit-helper
   (package
     (name "emacs-kibit-helper")