summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-07 11:55:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 11:56:18 +0100
commite942813aac7651986b556407956f61943578eb4d (patch)
tree4353bc5cdc48ba96f0f66cd8ddf4c072f5e2e352
parentad6f13308b1b3ee38ef76482bc597d9a9e1a31c2 (diff)
downloadguix-e942813aac7651986b556407956f61943578eb4d.tar.gz
gnu: Add mantis.
* gnu/packages/bioinformatics.scm (mantis): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d4661cf515..2a06a6e5ef 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -13285,6 +13285,39 @@ descriptive settings file.  The result is a set of comprehensive, interactive
 HTML reports with interesting findings about your samples.")
     (license license:gpl3+)))
 
+(define-public mantis
+  (let ((commit "4ffd171632c2cb0056a86d709dfd2bf21bc69b84")
+        (revision "1"))
+    (package
+      (name "mantis")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/splatlab/mantis.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0iqbr0dhmlc8mzpirmm2s4pkzkwdgrcx50yx6cv3wlr2qi064p55"))))
+      (build-system cmake-build-system)
+      (arguments '(#:tests? #f)) ; there are none
+      (inputs
+       `(("sdsl-lite" ,sdsl-lite)
+         ("openssl" ,openssl)
+         ("zlib" ,zlib)))
+      (home-page "https://github.com/splatlab/mantis")
+      (synopsis "Large-scale sequence-search index data structure")
+      (description "Mantis is a space-efficient data structure that can be
+used to index thousands of raw-read genomics experiments and facilitate
+large-scale sequence searches on those experiments.  Mantis uses counting
+quotient filters instead of Bloom filters, enabling rapid index builds and
+queries, small indexes, and exact results, i.e., no false positives or
+negatives.  Furthermore, Mantis is also a colored de Bruijn graph
+representation, so it supports fast graph traversal and other topological
+analyses in addition to large-scale sequence-level searches.")
+      (license license:bsd-3))))
+
 (define-public r-diversitree
   (package
     (name "r-diversitree")