summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 00:02:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commit307a0dcea388712ccd116899e8eb30d13ace54bc (patch)
treec2cb3716d727e591c50591b3ee3a10eae3bd4c34
parent8b0346f0827d20ac3de87ade9969108f070c2fae (diff)
downloadguix-307a0dcea388712ccd116899e8eb30d13ace54bc.tar.gz
gnu: ghc-diff: Update to 0.3.4.
* gnu/packages/haskell.scm (ghc-diff): Update to 0.3.4.
[native-inputs]: Add ghc-quickcheck, ghc-test-framework, and
ghc-test-framework-quickcheck2.
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ce74e4939d..b4ac74cab6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4874,15 +4874,19 @@ providing the PCRE backend to accompany regex-base, with bundled code from
 (define-public ghc-diff
   (package
     (name "ghc-diff")
-    (version "0.3.2")
+    (version "0.3.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
                                   "Diff/Diff-" version ".tar.gz"))
               (sha256
                (base32
-                "13iqqmpadcm7fvqwbfrz94w030rvjh66w2bdls1253128ac2n0vz"))))
+                "0bqcdvhxx8dmqc3793m6axg813wv9ldz2j37f1wygbbrbbndmdvp"))))
     (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
     (home-page "http://hub.darcs.net/sterlingclover/Diff")
     (synopsis "O(ND) diff algorithm in Haskell")
     (description