summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-08-29 00:33:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-10-14 22:50:27 -0400
commit66a9f08bb9c9ba2d7cd4ee3c2d48ea9a8e41c2c4 (patch)
tree0a1adda388fd71c90696c88d7b13c7f067f089db
parentbb840999c8592b0077c78170e135b59bc79638ed (diff)
downloadguix-66a9f08bb9c9ba2d7cd4ee3c2d48ea9a8e41c2c4.tar.gz
gnu: Add python-falcon-cors.
* gnu/packages/python-web.scm (python-falcon-cors): New variable.
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 77fb99dc56..f8052458a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -181,6 +181,32 @@ classes
 (define-public python2-falcon
   (package-with-python2 python-falcon))
 
+(define-public python-falcon-cors
+  (package
+    (name "python-falcon-cors")
+    (version "1.1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "falcon-cors" version))
+       (sha256
+        (base32
+         "12pym7hwsbd8b0c1azn95nas8gm3f1qpr6lpyx0958xm65ffr20p"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-falcon" ,python-falcon)))
+    (home-page
+     "https://github.com/lwcolton/falcon-cors")
+    (synopsis "Falcon @dfn{cross-origin resource sharing} (CORS) library")
+    (description "This middleware provides @dfn{cross-origin resource
+sharing} (CORS) support for Falcon.  It allows applying a specially crafted
+CORS object to the incoming requests, enabling the ability to serve resources
+over a different origin than that of the web application.")
+    (license license:asl2.0)))
+
+(define-public python2-falcon-cors
+  (package-with-python2 python-falcon-cors))
+
 (define-public python-furl
   (package
     (name "python-furl")