summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:59:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commit7044882ce75222f98bc1933665127184ba6a5f50 (patch)
treecacc8238c4930eb1087fb03058cb1aaa01e4871b
parentaebb8db28929a74f67cf3f2dcf28469c8efe4b0e (diff)
downloadguix-7044882ce75222f98bc1933665127184ba6a5f50.tar.gz
gnu: ghc-bifunctors: Update to 5.5.2.
* gnu/packages/haskell.scm (ghc-bifunctors): Update to 5.5.2.
[inputs]: Add ghc-base-orphans, ghc-comonad, ghc-th-abstraction, and
ghc-transformers-compat.
[native-inputs]: Add ghc-hspec, hspec-discover, and ghc-quickcheck.
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 839ba1e8df..bd5480d8f3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4268,7 +4268,7 @@ cross-site scripting (@dfn{XSS}) attacks.")
 (define-public ghc-bifunctors
   (package
     (name "ghc-bifunctors")
-    (version "5")
+    (version "5.5.2")
     (source
      (origin
        (method url-fetch)
@@ -4278,11 +4278,19 @@ cross-site scripting (@dfn{XSS}) attacks.")
              ".tar.gz"))
        (sha256
         (base32
-         "13990xdgx0n23qgi18ghhmsywj5zkr0a5bim0g8a4nzi0cx95ps1"))))
+         "04fbsysm6zl8kmvqgffmrqa9bxl9dl2gibrd51asqzg737mb4ark"))))
     (build-system haskell-build-system)
     (inputs
-     `(("ghc-tagged" ,ghc-tagged)
+     `(("ghc-base-orphans" ,ghc-base-orphans)
+       ("ghc-comonad" ,ghc-comonad)
+       ("ghc-th-abstraction" ,ghc-th-abstraction)
+       ("ghc-transformers-compat" ,ghc-transformers-compat)
+       ("ghc-tagged" ,ghc-tagged)
        ("ghc-semigroups" ,ghc-semigroups)))
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("hspec-discover" ,hspec-discover)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "https://github.com/ekmett/bifunctors/")
     (synopsis "Bifunctors for Haskell")
     (description "This package provides bifunctors for Haskell.")