summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 22:59:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 23:49:13 +0200
commit893c340c3af3fb1426d11f7a9f613f9837054ac5 (patch)
tree401f50e98e5a7ab5422e8632497b395772d07146
parentf825faa502b0c149c430a08268bc972ff5e8c1cd (diff)
downloadguix-893c340c3af3fb1426d11f7a9f613f9837054ac5.tar.gz
gnu: haveged: Update to 1.9.4.
* gnu/packages/linux.scm (haveged): Update to 1.9.4.
[source]: Use GIT-FETCH and GIT-FILE-NAME from new (development) home.
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d52e8d7d19..c6c5a585e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3737,15 +3737,16 @@ such as frequency and voltage scaling.")
 (define-public haveged
   (package
     (name "haveged")
-    (version "1.9.2")
+    (version "1.9.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://www.issihosts.com/haveged/haveged-"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jirka-h/haveged.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0w5ypz6451msckivjriwyw8djydlwffam7x23xh626s2vzdrlzgp"))))
+        (base32 "1hrwzjd4byq4fdrg8svww3d8x449k80jxxrjy9v6jvzhfv19rvxr"))))
     (build-system gnu-build-system)
     (home-page "http://www.issihosts.com/haveged")
     (synopsis "Entropy source for the Linux random number generator")