summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-15 03:42:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-15 06:19:37 +0200
commit9cac043cc02670fbec6964cc8f858c4b1e43dbfa (patch)
treeafa20aad06f576047bb68a335bb07f0734d8a7c1
parent3a6e1fe8c8dc7bb556f81568fc878310a15e03e3 (diff)
downloadguix-9cac043cc02670fbec6964cc8f858c4b1e43dbfa.tar.gz
gnu: restic: Update to 0.9.3.
* gnu/packages/backup.scm (restic): Update to 0.9.3.
[arguments]: Disable 'restic self-update'.
-rw-r--r--gnu/packages/backup.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 408b64b48d..52afcbc676 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -862,7 +862,7 @@ is like a time machine for your data. ")
 (define-public restic
   (package
     (name "restic")
-    (version "0.9.2")
+    (version "0.9.3")
     ;; TODO Try packaging the bundled / vendored dependencies in the 'vendor/'
     ;; directory.
     (source (origin
@@ -873,7 +873,7 @@ is like a time machine for your data. ")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "15bwkydxcg4xhrnqxvxji8wacrsndb1a6frj98wggfaijqzfx3lg"))))
+                "1l1ddnf61pfsrry97qwhhdzywin2mgnbrkhcc9pabsdfk602anmr"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/restic/restic"
@@ -887,6 +887,8 @@ is like a time machine for your data. ")
              (with-directory-excursion (string-append
                                         "src/github.com/restic/restic-"
                                         ,version)
+               ;; Disable 'restic self-update'.  It makes little sense in Guix.
+               (substitute* "build.go" (("selfupdate") ""))
                (invoke "go" "run" "build.go"))))
 
          (replace 'check