summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:47:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commitc2d30e31b93e8f264882492cc07d543d158993e4 (patch)
tree5f2ae14853807cbc703d0377c9453307304b5b41
parent41faaff11feb04375161ae20350bacf9bdbaed42 (diff)
downloadguix-c2d30e31b93e8f264882492cc07d543d158993e4.tar.gz
gnu: ghc-distributive: Update to 0.5.3.
* gnu/packages/haskell.scm (ghc-distributive): Update to 0.5.3.
[inputs]: Add ghc-base-orphans, ghc-semigroups, and ghc-generic-deriving.
[native-inputs]: Add ghc-doctest-0.12, cabal-doctest, hspec-discover and
ghc-hspec.
-rw-r--r--gnu/packages/haskell.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5ed06d5563..efa55eca9b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2572,7 +2572,7 @@ modifying, and extracting files from zip archives in Haskell.")
 (define-public ghc-distributive
   (package
     (name "ghc-distributive")
-    (version "0.4.4")
+    (version "0.5.3")
     (source
      (origin
        (method url-fetch)
@@ -2582,13 +2582,19 @@ modifying, and extracting files from zip archives in Haskell.")
              ".tar.gz"))
        (sha256
         (base32
-         "0s2ln9jv7bh4ri2y31178pvjl8x6nik5d0klx7j2b77yjlsgblc2"))))
+         "0y566r97sfyvhsmd4yxiz4ns2mqgwf5bdbp56wgxl6wlkidq0wwi"))))
     (build-system haskell-build-system)
-    (arguments `(#:tests? #f)) ; FIXME: fails with "cannot satisfy -package
-                               ; tagged-0.8.1".  Suspected Cabal issue.
     (inputs
      `(("ghc-tagged" ,ghc-tagged)
-       ("ghc-transformers-compat" ,ghc-transformers-compat)))
+       ("ghc-base-orphans" ,ghc-base-orphans)
+       ("ghc-transformers-compat" ,ghc-transformers-compat)
+       ("ghc-semigroups" ,ghc-semigroups)
+       ("ghc-generic-deriving" ,ghc-generic-deriving)))
+    (native-inputs
+     `(("cabal-doctest" ,cabal-doctest)
+       ("ghc-doctest" ,ghc-doctest-0.12)
+       ("ghc-hspec" ,ghc-hspec)
+       ("hspec-discover" ,hspec-discover)))
     (home-page "https://github.com/ekmett/distributive/")
     (synopsis "Distributive functors for Haskell")
     (description "This package provides distributive functors for Haskell.