summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-26 12:28:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-26 12:29:48 +0200
commit10275b7466853fce6d5b925f0267c20c304ba25a (patch)
tree9b4681b50e68442d65334b39a35e31bf3d3d9e38
parentfb4fcfab9d961726436d165252042a2e711bb6da (diff)
downloadguix-10275b7466853fce6d5b925f0267c20c304ba25a.tar.gz
gnu: python-openid: Update to 3.1.0.
* gnu/packages/python-web.scm (python-openid): Update to 3.1.0.
[arguments]: Update custom 'check phase.
[native-inputs]: Add python-coverage.
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a5b4b7578d..8412325377 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -509,27 +509,28 @@ is Python’s.")
 (define-public python-openid
   (package
     (name "python-openid")
-    (version "3.0.10")
+    (version "3.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python3-openid" version))
        (sha256
         (base32
-         "1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
+         "00l5hrjh19740w00b3fnsqldnla41wbr2rics09dl4kyd1fkd3b2"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
         (replace 'check
           (lambda _
-            (invoke "./admin/runtests")
-            #t)))))
+            (invoke "coverage" "run" "-m"
+                    "unittest" "openid.test.test_suite"))))))
     (properties `((python2-variant . ,(delay python2-openid))))
     (propagated-inputs
      `(("python-defusedxml" ,python-defusedxml)))
     (native-inputs
-     `(("python-psycopg2" ,python-psycopg2)
+     `(("python-coverage" ,python-coverage)
+       ("python-psycopg2" ,python-psycopg2)
        ("python-django" ,python-django)))
     (home-page "https://github.com/necaris/python3-openid")
     (synopsis "OpenID support for servers and consumers")