summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Lirzin <mathieu.lirzin@openmailbox.org>2014-09-28 01:29:56 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-29 00:16:28 +0200
commit182d6311c2bd3393115bac12da5154f8f33a9940 (patch)
tree3cffd554ed7cfe5529d3d84842d330cf0e1e0673
parentacf735f2be47165d9dcaf0feaeaa75e276c26e9f (diff)
downloadguix-182d6311c2bd3393115bac12da5154f8f33a9940.tar.gz
gnu: Add dionysus.
* gnu/packages/maths.scm (dionysus): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ebc34ccd87..e4fd13abf3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -84,6 +85,29 @@ effectively as a scientific calculator.")
    (license license:gpl3+)
    (home-page "http://www.gnu.org/software/units/")))
 
+(define-public dionysus
+  (package
+    (name "dionysus")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/dionysus/dionysus-" version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "1aqnvw6z33bzqgd1ga571pnx6vq2zrkckm1cz91grv45h4jr9vgs"))))
+    (build-system gnu-build-system)
+    (inputs `(("tcl" ,tcl)))                      ;for 'tclsh'
+    (synopsis "Local search for universal constants and scientific values")
+    (description
+     "GNU Dionysus is a convenient system for quickly retrieving the values of
+mathematical constants used in science and engineering.  Values can be
+searched using a simple command-line tool, choosing from three databases:
+universal constants, atomic numbers, and constants related to
+semiconductors.")
+    (license license:gpl3+)
+    (home-page "http://www.gnu.org/software/dionysus/")))
+
 (define-public gsl
   (package
     (name "gsl")