summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-12-23 18:46:06 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-24 16:10:14 +0100
commit311462f642dd87ca488bf9af180b2c609ea6e788 (patch)
tree96f37b9a2b2e598056860f6094f4fa621070264e
parented7b44370f71126087eb953f36aad8dc4c44109f (diff)
downloadguix-311462f642dd87ca488bf9af180b2c609ea6e788.tar.gz
gnu: Remove obsolete package gpgmepp.
This package is unused, is part of gpgme since version 1.7 and has been marked
as superseded since 18 months now.

* gnu/packages/kde-frameworks.scm (gpgmepp): Remove variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index bc28511d3f..988bf44c3d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -207,33 +207,6 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
     ;; license: source files mention "either version 2.1 or 3"
     (license (list license:lgpl2.1 license:lgpl3))))
 
-(define-public gpgmepp
-  (package
-    (name "gpgmepp")
-    (version "16.08.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://kde/stable/applications"
-                    "/" version "/src/"
-                    name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0828qlhdi1i26n2xgyb01c0q77m6jlppbxv6mprryxq0ma88940a"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)))
-    (propagated-inputs
-     `(("boost" ,boost)
-       ("gpgme" ,gpgme)))
-    (inputs
-     `(("qtbase" ,qtbase)))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "C++ bindings/wrapper for gpgme")
-    (description "C++ bindings/wrapper for gpgme.")
-    (license license:lgpl2.1+)
-    (properties `((superseded . ,gpgme)))))
-
 (define-public kpmcore
   (package
     (name "kpmcore")